Shooting the breeze Christchurch Gun Club  
Go Back   Shooting the breeze > The Chat > General Airgun Chat

General Airgun Chat Chat and banter that doesn't fit anywhere else...

Thread Tools Display Modes
Old 2nd October 2014, 11:08 AM
Akita Akita is offline
Senior Member
Join Date: Sep 2013
Member of: Greyhound & Purley Chase
Location: UK
Posts: 188

Did to replace the cracked belleville washer?
If you didnt replace it with the correct size bellleville the regulator wont work at the correct pressure.

If i recall correctly the high pressure stack of bellleville washers the washer are slightly thicker then the low pressure stock bellleville washers so dont mix them up.
Reply With Quote
Old 2nd October 2014, 03:02 PM
daiboy daiboy is offline
Join Date: Sep 2014
Location: wales
Posts: 57
Default Regulator

Originally Posted by waynegal View Post
I stripped my reg ,cleaned ,made new seals and re assambled.Don`t know what happened but power dropped to 645ft/ps and after 10 minutes rest I get the first shot 530 ,today I try calling factory in germany maybe I send regulator for an overhaul if they accept ,otherwise I don`t know.

was your regulator threads bonded with some sort of thread-lock when it was fitted to the action part of the rifle, I believe the Regulator units threads are bonded.

Last edited by daiboy; 2nd October 2014 at 05:24 PM.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hammerli AR 30 PCP FT OLD FART General Airgun Chat 4 17th September 2010 02:21 PM

All times are GMT. The time now is 01:34 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Skin design and concept by Attitude