Thread: EV2 Reg problem
View Single Post
Old 13th December 2012, 11:29 AM
thebaron thebaron is offline
Join Date: Jul 2012
Member of: Leics & District (Dowry Hill)
Location: Ashby - Leicestershire
Posts: 76
Default EV2 Reg problem

I bought a Mk2 EV2 6 months ago and when I chronographed it, it was very consistent giving about 140 shot at 780'/sec with AA Field from 200BAR down to 100BAR

The spread was +/- 5 ft/sec using pellets straight from the tin
As a benchrest rifle, it was brilliant and rarely threw a bad shot

However it recently has been playing up and putting in some bad shots particularly when the cylinder pressure drops to around 130 BAR (checked on bottle)

On the chrono now, using the same batch of pellets and filling at 200 BAR, it gives about 90 shots at +/-7 ft/sec, but then when the pressure drops to 130 BAR, the velocity goes up towards the 800 mark for about 20 shots and then drops again back down to 780'/sec

There is no AT on the gun, but playing with the power adjuster and the fine control on the transfer port does not cure the inconsistency. The hammer and the hammer bushes have no oil on them so that is not the problem

I can only think that the reg. pressure must now have climbed a bit to around 130 BAR, which would explain why the velocity increases when the cylinder pressure drops below this value

I have read the threads re. reg. issues on the EV2 and I would like to know how to reduce the reg. pressure slightly

The rifle is several years old and I don't think the reg. has been touched/serviced in the past

Any help/advice much appreciated

I live near Derby and have heard that John Ostler is a good man with regulators
Reply With Quote
Connect With Facebook to "Like" This Thread